U.S. CitiesCity-Data Forum Index
Go Back   City-Data Forum > General Forums > Automotive
 [Register]
Please register to participate in our discussions with 2 million other members - it's free and quick! Some forums can only be seen by registered members. After you create your account, you'll be able to customize options and access all our 15,000 new posts/day with fewer ads.
View detailed profile (Advanced) or search
site with Google Custom Search

Search Forums  (Advanced)
 
 
Old 06-03-2011, 04:33 PM
 
6 posts, read 49,431 times
Reputation: 11

Advertisements

I have a 98 GMC Savana 5.7L V8 engine. When it sits over night it takes forever to start in the morning. During the day it starts fine if it hasn't been sitting long before starting it again. The fuel pump activates when key is turned to on position. This van has new spark plugs, relatively new air filter, new fuel filter, and I've used about a half bottle of fuel injector cleaner in it. I don't see any fuel leaks and I've smelled the oil and it does not smell like gas.

I've taken pressure readings:

After running and then sitting for 30-60min: 0 psi
Key turned to on position: 62 psi and then slowly drops
Running idle: 52 psi
Normal idle psi: 60-66

I'm thinking either I have a bad fuel pressure regulator or a bad check valve in the fuel pump/defective fuel pump.

Any tips/advice/diagnosis would be greatly appreciated.

Andrew
Quick reply to this message

 
Old 06-03-2011, 05:44 PM
 
Location: Eastern Washington
12,883 posts, read 41,398,734 times
Reputation: 10580
Hi, welcome to the forums.

This sounds like a check valve problem, or possibly a weak fuel pump - have you tested the fuel pressure on the van stone cold?

Could be the regulator as well.

Have you measured the fuel pump amp draw?
Quick reply to this message
 
Old 06-03-2011, 05:55 PM
 
6 posts, read 49,431 times
Reputation: 11
Thank you. I haven't tested pressure with engine completely cold yet, but I'm assuming it will be 0 psi since i tested it within an hour of running and it was 0. I have not measured amp draw. How do you do that? I have a multimeter. Will that single out if it is the check valve or regulator? The pump seems to work fine when it is driven. It's just in the morning when I leave for work when it takes a while to charge the pressure back up. I have been turning the key back and forth from off to on to get the pressure up and that seems to help.
Quick reply to this message
 
Old 06-03-2011, 06:24 PM
 
6,368 posts, read 13,007,490 times
Reputation: 5849
That system is very sensitive to fuel pressure. As little as 5psi under spec will cause a no start.

Google - 98 GMC Savana 5.7L fuel injection diagnosis - go to the eighth result, an article from underhood service.com (it wouldn't allow a link). Lots and lots info good there. Hope it helps.



"When the key is turned off, the pressure in the fuel line should hold for at least five minutes. If the pressure drops off, the fuel pressure regulator or fuel pump check valve may be leaking. If pinching off the fuel return line produces the same results, the problem is the check valve in the fuel pump (replace the pump). If pinching off the return line stops the pressure loss, the problem is a leaky regulator."
Quick reply to this message
 
Old 06-03-2011, 06:43 PM
 
Location: Eastern Washington
12,883 posts, read 41,398,734 times
Reputation: 10580
I don't know the specifics on checking amps on this particular fuel pump. I guess just given the information you have posted, OP, it could be either a weak fuel pump or the fuel pressure regulator being "off". I would say check for any vacuum leak in the line to the FP regulator, but a vacuum leak on that line would make the pressure tend high, unless it's different from all the regulators I have seen.

Offhand, I would guess that if the fuel pump was weak, you would have poor running at higher loads, moreso than the pressure regulator, but maybe the regulator would screw with high-load running as well. If you have a safe place to tromp down hard on the "loud pedal", do that and post back up what happens.

3 steps as usual has a good test procedure. I'm hoping for your sake it's the regulator, most domestics you have to drop the tank to get at the fuel pump/integrated check valve. You may or may not want to tackle that DIY. I'd make sure to get the best fuel pump I could since it's a bear to change, relatively speaking. The OEM Delco part may or may not be the best thing - I don't know.
Quick reply to this message
 
Old 06-03-2011, 09:08 PM
 
Location: Where nothing ever grows. No rain or rivers flow, Texas
1,085 posts, read 1,180,977 times
Reputation: 468
I wonder if you have a coldstart valve. Have you tried wide open throttle when starting? I dunno, its just something I would do out of frustration
Quick reply to this message
 
Old 06-04-2011, 11:32 AM
 
6 posts, read 49,431 times
Reputation: 11
I think I'm gonna have a chance today to mess around with it so I will try to find somewhere in the return line i can pinch without damaging it. I am hoping it's the regulator too. That is a $50 part. A good fuel pump for this model vehicle is $250. I want whatever is cheaper lol. I wouldn't mind changing the fuel pump though. It's not the work I'm scared of, it's the price. I don't want to pour money into this vehicle. It has 233,000 miles. Just needs to last another 6 months.

TimBomb: It does have a cold start valve. I haven't tried that but I don't think it would help much unless the coldstart valve can hold it's own fuel pressure.

Thank you everyone for your replies. You've been helpful.
Quick reply to this message
 
Old 06-05-2011, 04:57 PM
 
6 posts, read 49,431 times
Reputation: 11
Okay I removed the upper manifold. Black buildup all over everything underneath. The fuel meter body appears to be secured to the lower manifold by only one bolt (which was loose) when there are spots for 2. The fuel pressure regulator has black buildup all over it. There also appears to be oil in there, which is probably due to the upper manifold gasket being bad. The fuel injectors are the ones that are like little clips with mini valves on the end and the other ends go into the fuel meter body. When I remove the little clips (similar to removing an electrical connector) the tips look clean where the fuel is actually sprayed out but the outside of them have the buildup all over them. It's hard to tell if one is leaking. They don't have o-rings. I'm thinking I'll just replace the regulator and clean out all the buildup I can. Has anyone had a similar job to this before? I know that it shouldn't be dirty in there.
Quick reply to this message
 
Old 06-05-2011, 05:46 PM
 
6 posts, read 49,431 times
Reputation: 11
Also something notable is that there was no vacuum hose attached to the regulator and there wasn't a loose one under there.
Quick reply to this message
 
Old 06-06-2011, 08:00 AM
 
6,368 posts, read 13,007,490 times
Reputation: 5849
This may help

GMC/Chevy Light Truck: Central Port Fuel Injection Diagnosis
Quick reply to this message
Please register to post and access all features of our very popular forum. It is free and quick. Over $68,000 in prizes has already been given out to active posters on our forum. Additional giveaways are planned.

Detailed information about all U.S. cities, counties, and zip codes on our site: City-data.com.


 
Please update this thread with any new information or opinions. This open thread is still read by thousands of people, so we encourage all additional points of view.

Quick Reply
Message:
Over $104,000 in prizes was already given out to active posters on our forum and additional giveaways are planned!

Go Back   City-Data Forum > General Forums > Automotive
Similar Threads
Follow City-Data.com founder on our Forum or

All times are GMT -6.

2005-2017, Advameg, Inc.

City-Data.com - Archive 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32 - Top