U.S. CitiesCity-Data Forum Index
Happy Thanksgiving Day!
Go Back   City-Data Forum > General Forums > Automotive
 [Register]
Please register to participate in our discussions with 1.5 million other members - it's free and quick! Some forums can only be seen by registered members. After you create your account, you'll be able to customize options and access all our 15,000 new posts/day with fewer ads.
Jump to a detailed profile or search
site with Google Custom Search

Search Forums  (Advanced)
Business Search - 14 Million verified businesses
Search for:  near: 
 
 
Old 06-21-2012, 11:30 PM
 
Location: Auburn, WA
267 posts, read 888,284 times
Reputation: 205

Advertisements

A week and a half ago, my husband took our problem-free 2002 Jeep Liberty in for a routine oil change. It's got 115k on it, but has had regular maintenance and was running fine. The oil change shop says our radiator cap is bad and we need to have it replaced, so he oks it.

Monday, the engine overheats on the 3 mile drive home from the train station, red lining and stalling in our driveway (no steam). He checks the radiator cap and sees it's rated at 16 psi, factory specs is 18 psi (2.4 litre vs. 3.7). It sits on Tuesday and the shop swaps out a new radiator cap, 18 psi. On a drive this afternoon, the temp stays stable, but it starts stalling at a stop sign. After a rest, it starts up again. Stalls again pulling into a parking spot. Stalls again turning a corner. And again.

When it stalls, we still have lights and radio, but no power breaks or power steering. No weird noise, just quiet. Other that stalling, it starts right up. Fan is running. Our thermostat was replaced last year, as was the alternator. Could a wrong radiator cap have caused this or is it just a coincidence?

ETA: No check engine light or other warning light comes on

Last edited by secret_squirrel; 06-21-2012 at 11:42 PM..
Quick reply to this message

 
Old 06-22-2012, 07:14 AM
 
Location: South Jersey
7,785 posts, read 10,249,225 times
Reputation: 2141
No it would not cause that.. absolute coincidence.. The overheating issue may have damaged something else.. You have to look into what caused that first.
Quick reply to this message
 
Old 06-22-2012, 09:22 AM
 
Location: Keosauqua, Iowa
5,873 posts, read 6,267,576 times
Reputation: 6188
Was the coolant level low when you overheated? Using a cap rated for a lower pressure won't directly cause the vehicle to overheat , it will only allow the radiator to boil over at a lower temperature. So if it boiled over a little each day it might have lost enough coolant in a week to overheat.

If the coolant level wasn't low then the whole thing is probably unrelated to the cap. So we'd either be looking at something else that happened in the shop or a complete coincidence.

I don't think the stalling is related either way unless, as Frank suggested, the overheating may have caused something else to fail.
Quick reply to this message
 
Old 06-22-2012, 09:26 AM
 
2,737 posts, read 1,081,789 times
Reputation: 1785
Quote:
Originally Posted by secret_squirrel View Post
A week and a half ago, my husband took our problem-free 2002 Jeep Liberty in for a routine oil change. It's got 115k on it, but has had regular maintenance and was running fine. The oil change shop says our radiator cap is bad and we need to have it replaced, so he oks it.

Monday, the engine overheats on the 3 mile drive home from the train station, red lining and stalling in our driveway (no steam). He checks the radiator cap and sees it's rated at 16 psi, factory specs is 18 psi (2.4 litre vs. 3.7). It sits on Tuesday and the shop swaps out a new radiator cap, 18 psi. On a drive this afternoon, the temp stays stable, but it starts stalling at a stop sign. After a rest, it starts up again. Stalls again pulling into a parking spot. Stalls again turning a corner. And again.

When it stalls, we still have lights and radio, but no power breaks or power steering. No weird noise, just quiet. Other that stalling, it starts right up. Fan is running. Our thermostat was replaced last year, as was the alternator. Could a wrong radiator cap have caused this or is it just a coincidence?

ETA: No check engine light or other warning light comes on
First of all, there's a 99.9% chance that your radiator cap was perfectly fine. That is not a "wear part." But I'm sure they charged you a lot for that $5 part.

Second, unless they jacked with something else, simply replacing a radiator cap should not have caused that much drainage of the anti-freeze.


Basically, I would be royally PO'd at this "mechanic shop" and would raise holy hell with them. A perfectly fine-running car, that leaves their shop screwed up, is almost certainly not a coincidence.
Quick reply to this message
 
Old 06-22-2012, 09:28 AM
 
Location: Auburn, WA
267 posts, read 888,284 times
Reputation: 205
Thanks
Quick reply to this message
 
Old 06-22-2012, 11:07 AM
 
Location: San Francisco
2,696 posts, read 4,690,480 times
Reputation: 1274
Quote:
Originally Posted by secret_squirrel View Post
A week and a half ago, my husband took our problem-free 2002 Jeep Liberty in for a routine oil change. It's got 115k on it, but has had regular maintenance and was running fine. The oil change shop says our radiator cap is bad and we need to have it replaced, so he oks it.

Monday, the engine overheats on the 3 mile drive home from the train station, red lining and stalling in our driveway (no steam). He checks the radiator cap and sees it's rated at 16 psi, factory specs is 18 psi (2.4 litre vs. 3.7). It sits on Tuesday and the shop swaps out a new radiator cap, 18 psi. On a drive this afternoon, the temp stays stable, but it starts stalling at a stop sign. After a rest, it starts up again. Stalls again pulling into a parking spot. Stalls again turning a corner. And again.

When it stalls, we still have lights and radio, but no power breaks or power steering. No weird noise, just quiet. Other that stalling, it starts right up. Fan is running. Our thermostat was replaced last year, as was the alternator. Could a wrong radiator cap have caused this or is it just a coincidence?

ETA: No check engine light or other warning light comes on
The red lining most likely caused engine damage. He should have shut the car off as soon as he saw that.
Quick reply to this message
 
Old 06-22-2012, 11:12 AM
 
Location: NY
6,194 posts, read 5,341,610 times
Reputation: 6743
If the radiator fluid was significantly low, I would look very suspiciously at the cap myself... If the Lib's 3.7 is set to operate as "normal" with up to 18 lbs of pressure in the radiator, and they put a cap on that will start releasing pressure at 16 lbs, it may have spent a week slowly venting out radiator fluid. Once there isn't enough left, the engine overheats, which can cause all kinds of damage.
Quick reply to this message
 
Old 06-22-2012, 11:28 AM
 
Location: Keosauqua, Iowa
5,873 posts, read 6,267,576 times
Reputation: 6188
Quote:
Originally Posted by johnfrisco View Post
The red lining most likely caused engine damage. He should have shut the car off as soon as he saw that.
Stalling isn't a symptom of engine damage.
Quick reply to this message
 
Old 06-22-2012, 11:44 AM
 
2,255 posts, read 3,500,328 times
Reputation: 3336
Here's the problem SS, regardless of the cause of the stalling, yer looking to replace the car or engine pretty soon. Probably as soon as the first cold snap comes to your area. Aluminum engines do not tolerate excessive heat. I can assure you something is now broke, be it a metal part or a gasket. When the thermal differences of ambient air and combustion temps takes place this winter, you'll be looking for a mechanic or a car dealership to unload that Liberty. If it's in the budget, unload it NOW.

Unless the fools at the shop didn't bother to refill the radiator when they found a defective cap, a cap of 2lbs lighter will not cause the issues you have. While there may be no engine light, you need to have it checked for codes. Some of the auto parts houses have code readers and it's a free service. There's obviously something wrong under the hood and it may be as simple as a loose wire, bad ignition, etc. But that's not going to fix the unforgiving high heat damage that has already happened. The 3.7 has never been a stellar engine or a long life engine. You've just about got all your going to get from it. Hope you're in a position to buy something else.
Quick reply to this message
 
Old 06-22-2012, 06:33 PM
 
Location: Eastern Washington
8,800 posts, read 22,783,014 times
Reputation: 4769
Quite possible that the incorrect radiator cap was not only the wrong pressure, but the wrong length between the top of the cap and the disc that actually establishes the pressure on the radiator (I am assuming an old school type radiator cap on this Jeep - not the Euro style all-plastic cap...if so the pressure rating made no difference, since it didn't hold any pressure at all. I wouldn't think this would cause the Jeep to overheat, but possible it did.

As I have posted in hundreds of threads here, "stupid lube" quicky oil change outfits are nothing but trouble, stay away.
Quick reply to this message
Please register to post and access all features of our very popular forum. It is free and quick. Over $68,000 in prizes has already been given out to active posters on our forum. Additional giveaways are planned.

Detailed information about all U.S. cities, counties, and zip codes on our site: City-data.com.


 
Please update this thread with any new information or opinions. This open thread is still read by thousands of people, so we encourage all additional points of view.

Quick Reply
Message:
Over $84,000 in prizes was already given out to active posters on our forum and additional giveaways are planned!

Go Back   City-Data Forum > General Forums > Automotive
Similar Threads

All times are GMT -6.

2005-2014, Advameg, Inc.

City-Data.com - Archive 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25 - Top