U.S. CitiesCity-Data Forum Index
Go Back   City-Data Forum > General Forums > Automotive
 [Register]
Please register to participate in our discussions with 2 million other members - it's free and quick! Some forums can only be seen by registered members. After you create your account, you'll be able to customize options and access all our 15,000 new posts/day with fewer ads.
View detailed profile (Advanced) or search
site with Google Custom Search

Search Forums  (Advanced)
Reply Start New Thread
 
Old 08-09-2014, 06:12 AM
 
1,698 posts, read 2,029,425 times
Reputation: 2593

Advertisements

Quote:
Originally Posted by a32 cefiro View Post
Thank you for your feed back but i did get it diagnosed the only problem that showed up was the knock sensor so i changed it and scanned it again the diagnosis said system normal but it still cuts off
You might have had it scanned for codes and got a knock sensor code, but it was not professionally diagnosed. A code scan is not a diagnosis in most cases. It is only a first step.

Any decent automotive professional knows that a faulty knock sensor will not shut down your engine.

A proper diagnosis consists of the shop's tech driving the car until the symptom is duplicated and testing for spark, fuel etc. with the symptom present. A full-fledged scan tool should be attached at this time and the datastream examined. This costs money unlike a code pull at Autozone or similar, but should be less than the pointless replacement of a fuel pump and other parts.

If you paid a shop good money to diagnosis your car and all they said was bad knock sensor, shame on them.

Don in Austin
Reply With Quote Quick reply to this message

 
Old 08-13-2014, 06:35 AM
 
3 posts, read 18,003 times
Reputation: 10
Ok thanks for the advice
Reply With Quote Quick reply to this message
 
Old 08-13-2014, 10:31 AM
 
Location: Orlando, FL
218 posts, read 264,849 times
Reputation: 201
Had this happen to my old 2000 VW Passat. Would randomly cut out on me while I was stopped at a light, while starting the parked car, as well as while going 40-50 mph (putting me in a few dangerous situations). Initially I too looked at the ignition and fuel pump as problems.

It ended up being a few of the fuses that they stuff in the door panel that needed to be replaced. After that it ran perfectly. Could still be driving it if a guy didn't run a red light and collide into my car a year later, totaling it.

Your problem sounds electrical to me.
Reply With Quote Quick reply to this message
 
Old 11-12-2014, 10:42 AM
 
1 posts, read 1,797 times
Reputation: 10
I have a 1992 ford explorer truck.. I took it in for a tune up it ran perfect for about 2 days all of a sudden the check engine light came on, and it keeps shutting off i can de driving and come to a complete stop and it will just cut off..i had it idle up but yet its still cutting off.it cranks back up instantly runs for about 10 seconds and cuts right back off..please could someone tell me what going on with this truck before i torch it. I'm tired fumbling around with it , and cutting off.. I cant go through the drive threw window because it wont stay runnimg
Reply With Quote Quick reply to this message
 
Old 01-08-2015, 11:44 PM
 
1 posts, read 1,629 times
Reputation: 10
Nissan Murano 2006 it just jumps and drives like its almost going off slowly then it starts again
Reply With Quote Quick reply to this message
 
Old 02-27-2015, 05:15 PM
 
1 posts, read 1,541 times
Reputation: 10
I have a 1998 pontiac grand prix supercharged 3800, 137000 miles and my car does this. The car makes a funny ticking sound whenever I accelerate? Help me
Reply With Quote Quick reply to this message
 
Old 03-18-2015, 03:51 PM
 
1 posts, read 1,483 times
Reputation: 10
I have a 2001 BMW it runs fine when the temp is cool outside but as soon as it gets hot and you are sitting in traffic it shuts off. Has anyone have this happen to them before, could it be a fuel pump problem??
Reply With Quote Quick reply to this message
 
Old 03-30-2015, 04:25 PM
 
1 posts, read 1,432 times
Reputation: 10
I have a 1996 Chevrolet Cavalier 2.2 engine with the same exact problem..Just started in January it dies out every blue moon but always start back up after about 30 minutes..I'm frustrated and I don't want to just keep fixing things until I get to the problem!!! HELP PLEASE!
Reply With Quote Quick reply to this message
 
Old 06-02-2015, 04:32 PM
 
1 posts, read 1,309 times
Reputation: 10
My wife car does the same thing. She has a 2006 Nissan Maxima and lately it's been driving fine at first but after getting in and out running around taking care of business and I'm almost home, without no warning the car just shuts off..
Reply With Quote Quick reply to this message
 
Old 06-15-2015, 07:07 AM
 
1 posts, read 1,261 times
Reputation: 10
a 2002 saturn vue .driveing along and it will just shut down .i pull over turn off and restart..some times it goes for days or even longer.does it at all speeds.the other day did it 3 times
Reply With Quote Quick reply to this message
Please register to post and access all features of our very popular forum. It is free and quick. Over $68,000 in prizes has already been given out to active posters on our forum. Additional giveaways are planned.

Detailed information about all U.S. cities, counties, and zip codes on our site: City-data.com.


Reply
Please update this thread with any new information or opinions. This open thread is still read by thousands of people, so we encourage all additional points of view.

Quick Reply
Message:

Over $104,000 in prizes was already given out to active posters on our forum and additional giveaways are planned!

Go Back   City-Data Forum > General Forums > Automotive
Follow City-Data.com founder on our Forum or

All times are GMT -6.

© 2005-2018, Advameg, Inc.

City-Data.com - Archive 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35 - Top