U.S. CitiesCity-Data Forum Index
Go Back   City-Data Forum > General Forums > Science and Technology > Computers
 [Register]
Please register to participate in our discussions with 2 million other members - it's free and quick! Some forums can only be seen by registered members. After you create your account, you'll be able to customize options and access all our 15,000 new posts/day with fewer ads.
View detailed profile (Advanced) or search
site with Google Custom Search

Search Forums  (Advanced)
 
Old 09-17-2010, 08:37 AM
 
29 posts, read 75,051 times
Reputation: 18

Advertisements

My netgear print server has WEP and WPA - PSK as security choices.
My DLink router has WEP, WPA, WPA2, WPA2-Auto, as choices.

WEP works fine. Are any of the WPA choices compatible between the router and print server?

Thanks.
Reply With Quote Quick reply to this message

 
Old 09-17-2010, 11:14 AM
 
11,715 posts, read 36,330,137 times
Reputation: 7514
WEP is so insecure you may as well not use it. WPA or WPA2 are actually secure.
Reply With Quote Quick reply to this message
 
Old 09-17-2010, 12:27 PM
 
29 posts, read 75,051 times
Reputation: 18
Thanks, I want to switch, hence, the question again. Are any of the WPA choices compatible between the router and print server?

(Is WPA-PSK compatible with WPA2 or WPA2-Auto?)

Last edited by F150; 09-17-2010 at 12:55 PM..
Reply With Quote Quick reply to this message
 
Old 09-17-2010, 01:03 PM
 
11,715 posts, read 36,330,137 times
Reputation: 7514
All devices on the network must support whatever encryption you set on the router. The safest choice terms of compatibility is WPA-PSK/TKIP. Its older than WPA2 but still a billion times stronger than WEP and pretty much universally supported at this point.
Reply With Quote Quick reply to this message
 
Old 09-17-2010, 01:06 PM
 
Location: Las Flores, Orange County, CA
26,345 posts, read 83,895,661 times
Reputation: 17566
I'll admit I've been using WEP but I hid the SSID and (for awhile) I was MAC address filtering. I tried WPA but I must have been doing something wrong - couldn't get it to work.....will try again.

Using Linksys G wireless routers and wireless adapters.
Reply With Quote Quick reply to this message
 
Old 09-17-2010, 01:12 PM
 
11,715 posts, read 36,330,137 times
Reputation: 7514
Quote:
Originally Posted by Charles View Post
I'll admit I've been using WEP but I hid the SSID and (for awhile) I was MAC address filtering. I tried WPA but I must have been doing something wrong - couldn't get it to work.....will try again.

Using Linksys G wireless routers and wireless adapters.
Hiding the ssid and mac filtering don't really add anything to your security and it just makes configuration harder.

First, do you router configuration from a wired computer so you can't lock yourself out. Set the security to WPA-PSK TKIP and enter a passphrase. Don't use anything in the dictionary. When you go to configure the PC to connect, you may have to tell it to forget the settings you had before you changed the security. It should detect the new security and ask for the key, but very often it'll just say "can't connect" or it'll pretend to connect, then not actually work. So if you wipe out the saved settings for the network, it'll usually work.
Reply With Quote Quick reply to this message
 
Old 09-17-2010, 01:13 PM
 
29 posts, read 75,051 times
Reputation: 18
So I gather I cannot use WPA since none of the encription choices match.

netgear print server has WEP and WPA-PSK

DLink router has WEP, WPA, WPA2, WPA2-Auto
Reply With Quote Quick reply to this message
 
Old 09-17-2010, 01:14 PM
 
24,503 posts, read 35,955,968 times
Reputation: 12847
MAC Address filtering adds a level of difficulty, but it is really no more secure than WEP. A determined person can get in. Soon, WPA will also be cracked (as parallel streaming processing on video cards get faster). The best thing to do is use WPA2/AES with a very very long key. The second best thing to do is use the most secure option available on your hardware.

OP, as others suggested, it looks like WPA/TKIP is the way to go.

Also, WPA-PSK is the same thing as WPA. PSK is typically implied in consumer level hardware)
Reply With Quote Quick reply to this message
 
Old 09-17-2010, 01:16 PM
 
11,715 posts, read 36,330,137 times
Reputation: 7514
Quote:
Originally Posted by F150 View Post
So I gather I cannot use WPA since none of the encription choices match.

netgear print server has WEP and WPA-PSK

DLink router has WEP, WPA, WPA2, WPA2-Auto
They often use slightly different terms. If you set the DLink router to WPA, there will probably be a drop down for TKIP. WPA2-Auto should also work with older devices but not always. The industry doesn't coordinate very well.
Reply With Quote Quick reply to this message
 
Old 09-17-2010, 02:47 PM
 
29 posts, read 75,051 times
Reputation: 18
OK, Thanks everyone. It worked fine. I have WPA-PSK TKIP now and I have better security and I have learned something..

Anyone else doing this save yourself some time and blink the power to the router and print Server after the changes and save yourself some time wondering why it didn't work!!
Reply With Quote Quick reply to this message
Please register to post and access all features of our very popular forum. It is free and quick. Over $68,000 in prizes has already been given out to active posters on our forum. Additional giveaways are planned.

Detailed information about all U.S. cities, counties, and zip codes on our site: City-data.com.


Reply
Please update this thread with any new information or opinions. This open thread is still read by thousands of people, so we encourage all additional points of view.

Quick Reply
Message:

Over $104,000 in prizes was already given out to active posters on our forum and additional giveaways are planned!

Go Back   City-Data Forum > General Forums > Science and Technology > Computers
Follow City-Data.com founder on our Forum or

All times are GMT -6. The time now is 07:08 PM.

© 2005-2019, Advameg, Inc. · Please obey Forum Rules · Terms of Use and Privacy Policy · Bug Bounty

City-Data.com - Archive 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35 - Top