U.S. CitiesCity-Data Forum Index
Go Back   City-Data Forum > General Forums > Science and Technology > Cell Phones and Smartphones
 [Register]
Please register to participate in our discussions with 2 million other members - it's free and quick! Some forums can only be seen by registered members. After you create your account, you'll be able to customize options and access all our 15,000 new posts/day with fewer ads.
View detailed profile (Advanced) or search
site with Google Custom Search

Search Forums  (Advanced)
Reply Start New Thread
 
Old 08-01-2012, 12:41 PM
 
Location: 92037
4,631 posts, read 9,039,689 times
Reputation: 1946

Advertisements

Hey guys, I dont have my S3 yet, but should be getting it soon.

As far as the browser issue, I am almost certain you can nix the screen issue by downloading Google Chrome from Play. Their native browser has some customizations like the screen dim thing that is actually quite annoying.
Reply With Quote Quick reply to this message

 
Old 08-01-2012, 01:07 PM
 
Location: Limbo
6,487 posts, read 6,342,227 times
Reputation: 6264
Quote:
Originally Posted by MikeJaquish View Post
It is a nod to battery life, which is the Achilles heel to most smartphones.
My S3 is bright enough, that I turn it down sometimes in darker rooms. So, I guess it works overall.
That makes sense. I don't ever use full brightness because it really isn't necessary for me. Battery issues, however, are an issue. I guess it's what you get with a mini-computer in your palm.
Reply With Quote Quick reply to this message
 
Old 09-29-2012, 03:32 PM
 
1 posts, read 1,545 times
Reputation: 10
Default Brighten Samsung Galaxy S3 phones

I was having the same frustration with dimmed screens when internet browing and did the suggested disabling of automatic brightness in Settings. However I found success when I sent into Browser settings by clicking on menu and then on Brightness and colors. There is also an Automatic brightness button there so I unchecked the box and now I have bright screen also when I'm on the Internet!
Reply With Quote Quick reply to this message
 
Old 11-26-2012, 09:11 AM
 
1 posts, read 1,421 times
Reputation: 10
Default Browser settings

Can you tell me where Browser settings is located? I cannot find it.
Reply With Quote Quick reply to this message
 
Old 12-06-2012, 04:10 PM
 
1 posts, read 1,380 times
Reputation: 11
For the galaxy s3 pull down at the top of the phone where u see notifications in the option area that has wifi, bluetooth, gps scrool to see airplane mode, power saving, driving mode. The power saving option is on by default. If u unclick it the web will no longer be darkened at all hope this helps!
Reply With Quote Quick reply to this message
 
Old 12-06-2012, 05:54 PM
 
354 posts, read 460,208 times
Reputation: 279
Quote:
Originally Posted by pjwpa2 View Post
I was having the same frustration with dimmed screens when internet browing and did the suggested disabling of automatic brightness in Settings. However I found success when I sent into Browser settings by clicking on menu and then on Brightness and colors. There is also an Automatic brightness button there so I unchecked the box and now I have bright screen also when I'm on the Internet!
yap that's what i did too. surprised by the dim light when browsing too. that solved the issue
Reply With Quote Quick reply to this message
 
Old 02-05-2013, 09:05 AM
 
1 posts, read 1,249 times
Reputation: 10
Default Dimming issues

I've read every thread on here due to having the same issue you all are having. I received my new Galaxy III yesterday and was loving it until i experienced the problem you all are having. I did everything that was posted and didn't have any luck at all. Being it was new I had alot of my apps needing updates so i just assumed after i did all the updates this would solve the problem.... didnt
Last ditch effort, went into "settings" went to the very bottom and hit "about phone"...thought what the heck i'll do a software update!!! MAGIC!!!! solved the dim screen....i now am so excited about this phone....give it a try all!!!!
Reply With Quote Quick reply to this message
 
Old 03-30-2013, 03:13 PM
 
1 posts, read 1,168 times
Reputation: 10
you have to disable the power saving mode
Reply With Quote Quick reply to this message
 
Old 03-10-2014, 09:18 AM
 
1 posts, read 716 times
Reputation: 10
Smile Power Save mode

I couldn't figure it out either. Then in settings I turned the power save switch to off & now when I get on the internet the brightness doesn't change. So that's the solution.
Reply With Quote Quick reply to this message
Please register to post and access all features of our very popular forum. It is free and quick. Over $68,000 in prizes has already been given out to active posters on our forum. Additional giveaways are planned.

Detailed information about all U.S. cities, counties, and zip codes on our site: City-data.com.


Reply
Please update this thread with any new information or opinions. This open thread is still read by thousands of people, so we encourage all additional points of view.

Quick Reply
Message:

Over $104,000 in prizes was already given out to active posters on our forum and additional giveaways are planned!

Go Back   City-Data Forum > General Forums > Science and Technology > Cell Phones and Smartphones
Similar Threads
Follow City-Data.com founder on our Forum or

All times are GMT -6.

© 2005-2020, Advameg, Inc. · Please obey Forum Rules · Terms of Use and Privacy Policy · Bug Bounty

City-Data.com - Archive 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35 - Top