Welcome to City-Data.com Forum!
U.S. CitiesCity-Data Forum Index
Go Back   City-Data Forum > General Forums > Automotive > Brand-specific forums > Chevrolet, Cadillac, Buick, and GMC
 [Register]
Please register to participate in our discussions with 2 million other members - it's free and quick! Some forums can only be seen by registered members. After you create your account, you'll be able to customize options and access all our 15,000 new posts/day with fewer ads.
View detailed profile (Advanced) or search
site with Google Custom Search

Search Forums  (Advanced)
 
Old 03-01-2017, 08:18 AM
 
37,315 posts, read 59,832,630 times
Reputation: 25341

Advertisements

My husband bought 2015 Tahoe loaded, new about 2 yrs ago
The nav system has shown a problem since he bought it--but he would never take it back to dealer for service
Just irrationally stubborn at times
The system at times wont "turn on"--blank screen entirrly.
He can usually correct it by turning off ignition, getting out of car, locking it, and then starting remotely.
Then he gets into the car and restarts it and nav starts up like it should.

Today he started car and maps shows loading but wont finish
Stoped/started inside and outside garage.
Tried remote start couple of times to no avail

Camera works
Bluetooth works and voice command to call contacts works

Just no NAV
Any suggestions?
We are on roadtrip we have done many times but NAV/map is just helpful anytime
Reply With Quote Quick reply to this message

 
Old 03-01-2017, 08:20 AM
 
37,315 posts, read 59,832,630 times
Reputation: 25341
Quote:
Originally Posted by loves2read View Post
My husband bought 2015 Tahoe loaded, new about 2 yrs ago
The nav system has shown a problem since he bought it--but he would never take it back to dealer for service
Just irrationally stubborn at times
The system at times wont "turn on"--blank screen entirrly.
He can usually correct it by turning off ignition, getting out of car, locking it, and then starting remotely.
Then he gets into the car and restarts it and nav starts up like it should.

Today he started car and maps shows loading but wont finish
Stoped/started inside and outside garage.
Tried remote start couple of times to no avail

Camera works
Bluetooth works and voice command to call contacts works

Just no NAV
Any suggestions?
We are on roadtrip we have done many times and have Iphones
but NAV/map is just helpful anytime
Wont be back to house til Fri
Reply With Quote Quick reply to this message
 
Old 03-01-2017, 09:32 AM
 
1,413 posts, read 1,290,389 times
Reputation: 4338
This is an expensive newer car that is still under warranty. I don't understand why your husband would be so stubborn as to not take it to the dealer to have them correct the problem. That is the solution. Even if you're on the road, go to the nearest Chevy dealer. It could be a quick fix.
Reply With Quote Quick reply to this message
 
Old 03-03-2017, 07:41 PM
 
13,131 posts, read 20,968,136 times
Reputation: 21410
Very simple fix and a known problem. You will need to take it to the dealer and they will run some diagnostics. They will tell you the interface module is shot and they need to order a new one for your vehicle. They will call you in a few days to schedule the service. From the time of the diagnostics and the actual FREE WARRANTY REPAIR, your OnSt*r, cell phone connectivity and all that communications and interface stuff may stop working. Some people say that during the diagnostics, the module fried up so you have no communications until fixed. Oh did I mention this is a free warranty repair?
Reply With Quote Quick reply to this message
 
Old 03-04-2017, 08:32 AM
 
37,315 posts, read 59,832,630 times
Reputation: 25341
We don't use OnStar---have had no problems w/the Bluetooth feature

We think it might have been a satellite issue since there was heavy cloud cover...

Anyway MAPS had no other problem on this trip...

Thanks for the responses
Reply With Quote Quick reply to this message
 
Old 03-04-2017, 12:13 PM
 
13,131 posts, read 20,968,136 times
Reputation: 21410
Quote:
Originally Posted by loves2read View Post
We think it might have been a satellite issue since there was heavy cloud cover...
????? Cloud cover for 2 YEARS ?????

Quote:
Originally Posted by loves2read View Post
My husband bought 2015 Tahoe loaded, new about 2 yrs ago
The nav system has shown a problem since he bought it--but he would never take it back to dealer for service
I'll repeat:
This is a known issue!
The "radio" is a complex unit made up of several modules that talk to each other. That "radio" on the dash is just a part of the entire system. The OTA radio, the satellite radio, the navigation gps, the on-board monitor, the on-star system, the key fobs, the cell phone interface, the ............ All these work in harmony via a module that serves as the traffic cop of information on what to display on what screen in what fashion and in what order. That module has been known to go bad. Indicators are blank screens, wrong gps location, information displayed form previous startups, keyfob intermittent and just about anything that is connected to the vehicle's communications systems.

Sounds more like you are just afraid to go to the dealer for your free warranty work. If that's the case, you can try and but a module from an after market seller and install it yourself. Of course, until you do so, you always run the risk of the vehicle refusing to start via the remote start and refusing to display anything on the nav, radio or event he dashboard.
Reply With Quote Quick reply to this message
 
Old 03-06-2017, 05:58 PM
 
Location: San Antonio, Tx
8,238 posts, read 10,721,107 times
Reputation: 10224
It's a free dealer fix. There is really no other correct answer.
Reply With Quote Quick reply to this message
 
Old 04-16-2017, 01:31 PM
 
37,315 posts, read 59,832,630 times
Reputation: 25341
Quote:
Originally Posted by Rabrrita View Post
????? Cloud cover for 2 YEARS ?????



I'll repeat:
This is a known issue!
The "radio" is a complex unit made up of several modules that talk to each other. That "radio" on the dash is just a part of the entire system. The OTA radio, the satellite radio, the navigation gps, the on-board monitor, the on-star system, the key fobs, the cell phone interface, the ............ All these work in harmony via a module that serves as the traffic cop of information on what to display on what screen in what fashion and in what order. That module has been known to go bad. Indicators are blank screens, wrong gps location, information displayed form previous startups, keyfob intermittent and just about anything that is connected to the vehicle's communications systems.

Sounds more like you are just afraid to go to the dealer for your free warranty work. If that's the case, you can try and but a module from an after market seller and install it yourself. Of course, until you do so, you always run the risk of the vehicle refusing to start via the remote start and refusing to display anything on the nav, radio or event he dashboard.
I haven't been back to check the response since the last two--but will say this--RUDE--people

This has not been a 2 yr problem because of cloud cover--
If you bothered to read--it has been an INTERMITTANT problem
And once clouds cleared up we had no more issues with it on that trip--nor subsequently

We HAVE taken our cars--various other models and this one--in for dealer warranty work--in fact this car has had NO work done on it other than at a Chevy/GM dealer...

We are planning trip to house in FL in next couple of weeks and I will check with my husband as to whether he wants to take this Tahoe in for dealer check before we go...

Making personal slams about people you have no real contact with is going off the deep end...
Reply With Quote Quick reply to this message
 
Old 04-17-2017, 01:57 PM
 
13,131 posts, read 20,968,136 times
Reputation: 21410
Yet, you are still playing stupid games over taking a warranty product in for warranty repairs!

Lets be honest, is your husband having an affair with the girl in sales at the dealership and you don't want him near the place? That is certainly a reason we can all understand for not going to the dealer to have it fixed. Unless, you guys busted it by trying to upload bootlegged maps from russia and you don't want them to see your hack. Or, did you accidentally tried cleaning the screen with sulfuric acid? Unless you did some really horrible thing to the unit, I still can't imagine why a sensible rational human being would complain about a problem yet be act all wimpy and childish about taking it in for repairs that are clearly covered by warranty. Com'on, tell us what you did to that poor radio......
Reply With Quote Quick reply to this message
 
Old 06-10-2017, 12:50 PM
 
Location: Midwest
9,401 posts, read 11,147,212 times
Reputation: 17878
Quote:
Originally Posted by loves2read View Post
My husband bought 2015 Tahoe loaded, new about 2 yrs ago
The nav system has shown a problem since he bought it--but he would never take it back to dealer for service
Just irrationally stubborn at times
The system at times wont "turn on"--blank screen entirrly.
He can usually correct it by turning off ignition, getting out of car, locking it, and then starting remotely.
Then he gets into the car and restarts it and nav starts up like it should.

Today he started car and maps shows loading but wont finish
Stoped/started inside and outside garage.
Tried remote start couple of times to no avail

Camera works
Bluetooth works and voice command to call contacts works

Just no NAV
Any suggestions?
We are on roadtrip we have done many times but NAV/map is just helpful anytime
Get logic chip installed in husband.
Reply With Quote Quick reply to this message
Please register to post and access all features of our very popular forum. It is free and quick. Over $68,000 in prizes has already been given out to active posters on our forum. Additional giveaways are planned.

Detailed information about all U.S. cities, counties, and zip codes on our site: City-data.com.


Reply
Please update this thread with any new information or opinions. This open thread is still read by thousands of people, so we encourage all additional points of view.

Quick Reply
Message:

Over $104,000 in prizes was already given out to active posters on our forum and additional giveaways are planned!

Go Back   City-Data Forum > General Forums > Automotive > Brand-specific forums > Chevrolet, Cadillac, Buick, and GMC
Similar Threads

All times are GMT -6.

© 2005-2024, Advameg, Inc. · Please obey Forum Rules · Terms of Use and Privacy Policy · Bug Bounty

City-Data.com - Contact Us - Archive 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37 - Top