Welcome to City-Data.com Forum!
U.S. CitiesCity-Data Forum Index
Go Back   City-Data Forum > General Forums > Automotive > Brand-specific forums > Chevrolet, Cadillac, Buick, and GMC
 [Register]
Please register to participate in our discussions with 2 million other members - it's free and quick! Some forums can only be seen by registered members. After you create your account, you'll be able to customize options and access all our 15,000 new posts/day with fewer ads.
View detailed profile (Advanced) or search
site with Google Custom Search

Search Forums  (Advanced)
Reply Start New Thread
 
Old 08-09-2019, 03:10 PM
 
Location: ☀️ SFL (hell for me-wife loves it)
3,671 posts, read 3,553,488 times
Reputation: 12346

Advertisements

Just some information for others that may have this problem.

In my Chevy Express 3500, I had the exact same symptom. It ended up being a fuse. As soon as it was replaced, the van ran like a charm. Start with the small stuff first folks.
Reply With Quote Quick reply to this message

 
Old 08-10-2019, 12:09 AM
 
1 posts, read 604 times
Reputation: 10
I have the same issue. We changed the Mass AirFlow Sensor, but still the same. Please let me know if you were able to fix the issue and how.
Reply With Quote Quick reply to this message
 
Old 03-25-2020, 01:58 PM
 
1 posts, read 434 times
Reputation: 10
Quote:
Originally Posted by Cruzecruze View Post
We’re u able to fix this problem and how, I am facing the same issue
I have a 2011 Cruze 130k miles same valve cover, same intake (pcv original), it sometimes stalls at a redlight, no codes, I just installed new plugs same problem, it did it with my 82 year old sister driving and she freaked in traffic. It randomly does it, you stop for a red light or stop sign and it is idling good than starts to vibrate than die. Turn the key it starts and idles good......Help
Reply With Quote Quick reply to this message
 
Old 03-25-2020, 03:44 PM
 
Location: Born + raised SF Bay; Tyler, TX now WNY
8,481 posts, read 4,727,776 times
Reputation: 8390
That smacks of a vacuum leak to me. It runs fine when you are at speed? I don’t know why they are trying to sell you an injector. If it were at fault, you would most likely get a misfire code, and the car would run at least as bad as it does at idle, if not worse, when rolling down the road. Try opening the hood and see if you can hear a hissing sound as it takes air in somewhere. You probably won’t be able to, you can also use a spray bottle with water in it and see if you can hear it getting slurped in.
Reply With Quote Quick reply to this message
Please register to post and access all features of our very popular forum. It is free and quick. Over $68,000 in prizes has already been given out to active posters on our forum. Additional giveaways are planned.

Detailed information about all U.S. cities, counties, and zip codes on our site: City-data.com.


Reply
Please update this thread with any new information or opinions. This open thread is still read by thousands of people, so we encourage all additional points of view.

Quick Reply
Message:


Over $104,000 in prizes was already given out to active posters on our forum and additional giveaways are planned!

Go Back   City-Data Forum > General Forums > Automotive > Brand-specific forums > Chevrolet, Cadillac, Buick, and GMC
Similar Threads

All times are GMT -6.

© 2005-2024, Advameg, Inc. · Please obey Forum Rules · Terms of Use and Privacy Policy · Bug Bounty

City-Data.com - Contact Us - Archive 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37 - Top