U.S. CitiesCity-Data Forum Index
Covid-19 Information Page
Go Back   City-Data Forum > General Forums > Garden
 [Register]
Please register to participate in our discussions with 2 million other members - it's free and quick! Some forums can only be seen by registered members. After you create your account, you'll be able to customize options and access all our 15,000 new posts/day with fewer ads.
View detailed profile (Advanced) or search
site with Google Custom Search

Search Forums  (Advanced)
 
Old 04-10-2015, 03:19 PM
 
1 posts, read 859 times
Reputation: 10

Advertisements

We we live in zone 9 and planted a redbud whip (about 1 gal pot) around the 1st of the year in an area that gets full sun until early to mid afternoon. The soil is sandy/silty and we added some compost at the time of planting. It is being watered every few days. It is just now finished blooming and is putting on lots of new foliage. I would say that the tree is healthy and vigorous except the new foliage is rather droopy. Is it normal for new leaves to be somewhat limp for a while?
Thanks
Reply With Quote Quick reply to this message

Reply
Please update this thread with any new information or opinions. This open thread is still read by thousands of people, so we encourage all additional points of view.

Quick Reply
Message:

Over $104,000 in prizes was already given out to active posters on our forum and additional giveaways are planned!

Go Back   City-Data Forum > General Forums > Garden
Similar Threads
Follow City-Data.com founder on our Forum or

All times are GMT -6. The time now is 03:07 PM.

© 2005-2020, Advameg, Inc. · Please obey Forum Rules · Terms of Use and Privacy Policy · Bug Bounty

City-Data.com - Contact Us - Archive 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37 - Top